[gst-devel] unable to get gst-app to work...

Phil Pellouchoud Phil at slacker.com
Fri Mar 28 19:24:06 CET 2008

Oh, by the way, when I do add that (i.e. follow what it says), that
message goes away, but I still get the message box coming up (and then
crashing the app).




From: gstreamer-devel-bounces at lists.sourceforge.net
[mailto:gstreamer-devel-bounces at lists.sourceforge.net] On Behalf Of Phil
Sent: Friday, March 28, 2008 11:21 AM
To: gstreamer-devel at lists.sourceforge.net
Subject: [gst-devel] unable to get gst-app to work...


I am having trouble getting gst-app to work.  When I run it, I get:


** (app.exe:5908): WARNING **: The GStreamer function
gst_init_get_option_group() was

        called, but the GLib threading system has not been initialised

        yet, something that must happen before any other GLib function

        is called. The application needs to be fixed so that it calls

           if (!g_thread_supported ()) g_thread_init(NULL);

        as very first thing in its main() function. Please file a bug

        against this application.

Trying to play file:///c:/hold.mp3 ...


I am running on a WinXPSP2 system using OABuild.


And then it pops up with a message box that says:



| Error 


| (X)   ** ERROR **: Could not create GStreamer 'playbin' element.
Please install it

|          aborting...


|                                                                     [
OK ]




Any help would be greatly appreciated...



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20080328/405567fa/attachment.htm>

More information about the gstreamer-devel mailing list