[gst-devel] Cannot save H.264 bitstream in QuickTime (qtmux) file, error "failed to determine the time to mux"

Yiliang Bao yiliangb at gmail.com
Tue Oct 20 19:15:17 CEST 2009

Following is the pipeline I used:

gst-launch -e v4l2src ! ffmpegcolorspace ! x264enc ! qtmux ! filesink

The output from gst-launch is:

ERROR: from element /GstPipeline:pipeline0/GstQTMux:qtmux0: Could not
multiplex stream.
Additional debug info:
gstqtmux.c(1107): gst_qt_mux_add_buffer ():
Failed to determine time to mux.
Execution ended after 416709785 ns.

I also tried the following 2 pipelines and both of them are working fine.

gst-launch -e v4l2src ! ffmpegcolorspace ! qtmux ! filesink location=a.mov
gst-launch filesrc location=Videos/g.mov ! decodebin ! ffmpegcolorspace !
x264enc ! qtmux ! filesink location=a.mov

I have tried both webcam and TV capture card as the capture device, but got
the same result. 

Has anyone seen similar problem before? I found one post reporting the same
problem, but there was no followup.




View this message in context: http://www.nabble.com/Cannot-save-H.264-bitstream-in-QuickTime-%28qtmux%29-file%2C-error-%22failed-to-determine-the-time-to-mux%22-tp25979039p25979039.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list