[gst-devel] v4l2src0: Could not negotiate format

John Buckley buckleyassoc at comcast.net
Sat Oct 31 22:51:59 CET 2009

I've been trying to get an approved USB webcam (Creative Optia AF) to run
using GStreamer and sending the output to an  XWindow and I keep getting

I have the uvcvideo module loaded and /dev/video0 is present.

I am running openembedded on the Gumstix Verdex Pro XL6P.  Could it be that
the camera is USB 2.0 and the Verdex Pro is only rated for USB 1.1?

This is what I see when I plug the camera in...

root at gumstix-custom-verdex:~# usb 1-2: new full speed USB device using
pxa27x-ohci and address 4
usb 1-2: configuration #1 chosen from 1 choice
uvcvideo: Found UVC 1.00 device VF0560 Live! Cam Optia AF (041e:406d)
input: VF0560 Live! Cam Optia AF as
4:3:1: cannot get freq at ep 0x84

When I try to gst-launch with the v4lsrc or v4l2src elements and I get the
error below.  I have tried a variety of settings using the 'video/x-raw-rgb'
cap but I always get the same error.  The videotestsrc element works fine
with ximagesink.

root at gumstix-custom-verdex:~# gst-launch v4l2src ! ximagesink
Setting pipeline to PAUSED ...
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/GstV4l2Src:v4l2src0: Could not
negotiate format
Additional debug info:
gstbasesrc.c(2584): gst_base_src_start ():
Check your filtered caps, if any
Setting pipeline to NULL ...
Freeing pipeline ...
root at gumstix-custom-verdex:~# 

Any help would be greatly appreciated...
John Buckley

View this message in context: http://old.nabble.com/v4l2src0%3A-Could-not-negotiate-format-tp26146240p26146240.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list