[gst-devel] SDLVideoSink hangs on Windows

Marko Mikkonen mmikkone at mail.student.oulu.fi
Sat Sep 19 21:54:31 CEST 2009

I've compiled now GStreamer with MinGW for Windows, but I can't get 
SDLVideoSink to work. It hangs:

C:\TEMP\gstreamer test>gst-launch-0.10.exe filesrc 
location="H:/movies/test.avi" ! decodebin ! 
sdlvideosink --gst-plugin-path="c:\temp\gstreamer test"
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...

After this nothing happens. Gst-launch doesn't respond to ctrl-C and I have 
to kill the process in Task Manager. SDLAudioSink works fine. BTW I've 
compiled SDLSink plugin with both configure/make/make install and with 
CodeBlocks MinGW edition (created a new project for it). I got a lot less 
rubbish in the dll with CodeBlocks. I mean there was a lot of exported 
functions in the dll when I compiled it with Make. Compiling with CodeBlocks 
made only 5 functions exported.

How do I debug this? I'm completely new to debugging GStreamer. I tried to 
set breakpoints with CodeBlocks, but gdb is very slow to even catch the 
first breakpoint so I gave that up (has something to do with loading all 
those plugins in plugin directory???). I tried printing from SDLVideoSink - 
functions are only called once when making gstreamer registry (when I've 
deleted it) so I'm not becoming any wiser. Then I tried to use --gst-debug 
option with some debug categories, but I'm not really sure which ones to 
try. There are so many and there's a lot of output... Maybe you could point 
me to the right direction? Could this hanging be caused by a race condition 
somewhere (there's no eternal loop here: CPU usage stays minimal)?


More information about the gstreamer-devel mailing list