[gst-devel] Building gstreamer for ARM

Rodney Dowdall rdowdall at cranksoftware.com
Mon Jun 14 20:40:27 CEST 2010

If anyone else is having issues with a glibc version dependency, if you 
pass in --disable-gst-debug when configuring gstreamer, it removes the 
requirement for the specific version of glibc that you are compiling 


On 10-06-11 02:45 PM, Rodney Dowdall wrote:
> On 10-06-11 02:19 PM, David Schleef wrote:
>> On Fri, Jun 11, 2010 at 09:23:05AM -0400, Rodney Dowdall wrote:
>>> What dependency causes gstreamer to require a 2.10 version of glibc?  I
>>> thought it might be the register_printf_* calls, but getting rid of
>>> those didn't seem to get rid of the dependency.  I am trying to compile
>>> gstreamer for arm, and the board I have only has a 2.9 version of 
>>> glibc.
>> You are mistaken.  GStreamer does not require any particular
>> version of glibc.  Any software compiled against glibc-2.10 headers
>> might require 2.10 at runtim, however.
> Cool.  That's good to know.  Is there a reason why the objdump for 
> libgstreamer-0.10.so.0 would report that it requires GLIBC_2.10?  The 
> other libraries that I have built with the same compiler only list 
> that it needs GLIBC_2.4.
> Attached is the objdump output.
> Does anyone know of hand if there anyway I can remove the 2.10 
> dependency through a configure option, or a compiler flag?  Or at 
> least force it to a smaller version number that I specify?
> Thanks,
> Rodney
>> dave...

*Rodney Dowdall
**Crank Software Inc.
**Office*: 613-595-1999
*Online*: www.cranksoftware.com <http://www.cranksoftware.com/>
*Check out*: Crank Software's Blog <http://cranksoftware.com/blog/>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20100614/61374229/attachment.htm>

More information about the gstreamer-devel mailing list