[gst-devel] gst-launch line for use with VDR on BeagleBoard (was: [beagleboard] Re: remaining problems setting up VDR)

Paul Menzel paulepanter at users.sourceforge.net
Mon Jun 14 23:15:53 CEST 2010

Dear GStreamer folks,

the following problem was raised on the BeagleBoard list [1]. On the
BeagleBoard GStreamer is the preferred multimedia framework to use. We
want to use the PVR program VDR [2] with it.

Am Montag, den 14.06.2010, 08:13 -0700 schrieb T. Brinkmann:


> gstreamer does not work too well for me in this context. I can start
> watching streams provided by vdr/streamdev with something like:
> gst-launch -v gnomevfssrc location= !
> ffdemux_mpegts name=demux demux.audio_00  ! queue max-size-
> buffers=1200 max-size-time=0 max-size-bytes=0 ! mad ! alsasink
> demux.video_00 ! TIViddec2 codecName=mpeg2dec engineName=codecServer
> frameRate=25 numOutputBufs=4 ! queue max-size-buffers=2 max-size-
> time=0 max-size-bytes=0 ! TIDmaiVideoSink contiguousInputFrame=TRUE
> framerate=25 accelFrameCopy=TRUE
> I've tried several variations (including omapdmaifbsink instead of
> TIDmaiVideoSink), but whatever I do, I get this error:
> ERROR: from element /GstPipeline:pipeline0/GstTIViddec2:tividdec20:
> failed to get a free contiguous buffer from BufTab
> The only time I don't get it is when USB crashes first :(
> I've tried other buffer settings unsuccessfully. Any help would be
> appreciated.


It would be great if you could help us. If you need more information, I
will try to provide them to you.



[1] http://groups.google.com/group/beagleboard/msg/1b3fabd83fa9190e
[2] http://tvdr.de/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20100614/56dcd45c/attachment.pgp>

More information about the gstreamer-devel mailing list