Problem When Switching to the OSSBuild 10.0.7 Beta Version.

Sudarshan Bisht bisht.sudarshan at
Tue Aug 2 21:22:10 PDT 2011

It could be possible that you need to send end-of-stream event once pipeline
shuts down.

On Tue, Aug 2, 2011 at 11:20 PM, William Metcalf <wmetcalf at>wrote:

> Hello all,
> I recently upgraded to the OSSBuild version 10.0.7 because I needed to be
> able to use x264enc on Windows.  I have an application I wrote that worked
> perfectly in 10.0.6, but it is no longer working now.  It reads data from a
> capture card, encodes it, and writes it to a file.  The pipeline is
> essentially as follows:
> ----- appsrc max-bytes=0 is-live=true ! "video/x-raw-yuv,format=(**
> fourcc)UYVY,width=(int)720,**height=(int)486,framerate=(**fraction)30/1" !
> ffmpegcolorspace ! ffenc_mpeg4 ! mpeg4videoparse ! queue ! qtmux ! filesink
> location="Video.mp4"
> When I run this application it runs with no errors, but the video file
> produced is very very small and will not play.  I have also tried with
> mp4mux and it seems like just the header is getting written to the file.  I
> tried running a pipeline (appsrc ! videoparse ! autovideosink) and the video
> plays fine, so I know that the video data is getting pushed through the
> pipeline correctly.  I am not sure why the video is not getting written to
> the file, especially since it worked perfectly with the older version of
> gstreamer.  Is this a known bug with OSSBuild 10.0.7 or is there something
> that I am missing to make this work correctly.  (Also, I am able to stream
> the video over a network using rtp payloader and udpsink, so I am very
> confused as to why I can't write it to a file.)
> Thank you all for your help,
> William
> ______________________________**_________________
> gstreamer-devel mailing list
> gstreamer-devel at lists.**<gstreamer-devel at>


Sudarshan Bisht
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list