Transitions with ges-launch not working?

Rory McCann rory at
Tue Jul 26 08:07:38 PDT 2011


I'm trying to combine 2 videos together with a short transition between
the 2 videos. I've been trying with gnonlin for ages (both on command
line and python), and Luis suggest ges-launch (!/luisbg/status/93648693068169217 ), however it's
just not working for me.

I can use the command to combine the 2 videos, one plays after the other
with no transition. that works fine:

    ges-launch-0.10 0 5 5 5 -r -o

This results in a 10 second file that is 5 seconds of the first clip,
and then switches immediatly to 5 seconds of the second clip.

However when I tried to add a short transition between the two, it hangs.:

    ges-launch-0.10 0 5 +transition crossfade 2 5 5 -r -o file:///tmp/

The file is 0 bytes, and there is no CPU activity. It just sits
there doing nothing for ages, until I press Control-C on it.

For the record I asked on StackOverflow aswell:

The original videos (which play fine in gstreamer) are available for
download here (~10MB each):


I'm using Ubuntu Natty/11.04 and ges0.10-tools 0.10.1-1. I also tried
compiling GES from git recently and got the same results.

Does anyone have any ideas?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the gstreamer-devel mailing list