[gst-devel] simple raw video RTP -- still no joy

Jan Rübel ruebel at vrmagic.com
Mon May 2 08:08:24 PDT 2011


I'm having the same problem as Bert when using rtpvrawdepay. When I try to stream raw rgb video data, the pipeline runs, but does not display anything.
>From the debug information it seems that the srcpad of the depayloader
cannot link to the sinkpad of ffmpegcolorspace. If I use video/x-raw-yuv there is no such problem.

Below are the two actual pipelines I use. However, the problem also occurs when I start something like this:
gst-launch --verbose videotestsrc ! video/x-raw-rgb  ! rtpvrawpay !
rtpvrawdepay ! ffmpegcolorspace ! dshowvideosink Again, if I replace "rgb" by "yuv" the pipeline works fine. 

Sender pipeline: 
gst-launch --verbose  gstrtpbin name=r videotestsrc ! video/x-raw-rgb, width=320, height=120, bpp=32, depth=32, framerate=1/1 ! rtpvrawpay !
r.send_rtp_sink_0  r.send_rtp_src_0 ! udpsink host=... port=5000
r.send_rtcp_src_0 ! udpsink port=5001 sync=false async=false udpsrc
port=5002 ! r.recv_rtcp_sink_0

Receiver pipeline:
gst-launch gstrtpbin name=rtpbin udpsrc caps="application/x-rtp, media=(string)video, clock-rate=(int)90000, encoding-name=(string)RAW, sampling=(string)RGBA, depth=(string)8, width=(string)320, height=(string)120, colorimetry=(string)SMPTE240M" port=5000 !
rtpbin.recv_rtp_sink_0  rtpbin. ! rtpvrawdepay !
! ffmpegcolorspace ! dshowvideosink udpsrc port=5001 !
rtpbin.recv_rtcp_sink_0   rtpbin.send_rtcp_src_0 ! udpsink port=5002
sync=false async=false 

I am currently using the latest OSSBuild (0.10.7 beta4) but I have also tried (0.10.6).

Best regards

More information about the gstreamer-devel mailing list