in gst-template gives error

Stefan Kost ensonic at
Tue May 17 06:02:20 PDT 2011


Am 16.05.2011 23:56, schrieb Alex Song:
> Hello,
> I'm new to gstreamer and I'm trying to write a plugin. I started according to
> "Plugin Writer's Guide" and downloaded gst-template. But when I did
> ./
> I got
> src/ Libtool library used but `LIBTOOL' is undefined
> src/   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
> src/   to `' and run `aclocal' and `autoconf' again.
> src/   If `AC_PROG_LIBTOOL' is in `', make sure
> src/   its definition is in aclocal's search path.
> src/ installing `./depcomp'
> installing `./INSTALL'
> autoreconf: automake failed with exit status: 1
> failed
> I tried installing libtool 2.2.6b to /usr/local and tried to put
> AC_PROG_LIBTOOL to but they didn't help.

It would be better to install the libtool package from your distribution. If you
install it yourself to /usr/local chances are small that aclocal will pick up
the libtool.m4.

As an alternative you could get yourself the gst-plugin-bad package from git and
try gst-element-maker, this will take over gst-template (yes, the docs shall be


> How to fix this issue?
> Thanks very much,
> Alex
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at

More information about the gstreamer-devel mailing list