Problem in "mad" plugin for "armv7l" architecture

Ajay Garg ajaygargnsit at
Mon Mar 12 01:28:06 PDT 2012

Hi all.

I am wanting to run mp3s on a armv7l-based F14 (Fedora 14) machine.
I have tried the following steps ::

With great difficulty, I managed to compile "" for armv7l
architecture (on a Fedora-14).

I then copied "" to "/usr/lib/gstreamer-0.10/"

When I run,
_gst-launch filesrc location=/home/ajay/test.mp3 ! mad ! osssink_

I get the error :
_(gst-plugin-scanner:25078): GStreamer-WARNING **: Failed to load
plugin '/usr/lib/gstreamer-0.10/':
/usr/lib/gstreamer-0.10/ undefined symbol: id3_tag_query_

The above command runs flawlessly (and plays the mp3) on x86-based
F14, without any problems at all.

I have already ensured that "libid3tag" and "libid3tag-devel" packages
have been installed (those were necessary as part of
compilation/installation itself).

I have already googled, but found no answer.

Any ideas?
I will be grateful for any help provided.

Looking forward to a reply.

Thanks and Regards,

More information about the gstreamer-devel mailing list