Streaming of a text file

enricom enri_marne87 at
Fri Mar 30 03:28:35 PDT 2012

Hi! I'm a new user and i'm trying to build a pipeline that extracts teletext
subtitles from a transport stream and sends the text file (with subtitles
and timing info) to another computer through udpsink.

I'm able to create a text file with the subtitles (and I slightly modified
the teletext code to print the time as well) with: gst-launch  filesrc
location=/(...)TransportStream.ts  ! mpegtsdemux program-number=1 name=demux
demux.private_0001 ! teletextdec page=100 subtitles-mode= "true"
subtitles-template="%s\n" ! 'text/plain' ! filesink

The output file is created in real-time, as soon as the teletext decoder
receives data.
But then I fail to send this file to another computer: I tried with this

gst-launch filesrc location=(...)/Transportstream.ts ! mpegtsdemux
program-number=1 name=demux demux.private_0001 ! teletextdec page=100
subtitles-mode="true" ! 'text/plain' ! udpsink port=6000 async="false" \
udpsrc port=6000 ! filesink location= (...)/teletext.txt
but, even if I can see the decoding process  working correctly in the debug
window, no file is created. I tried adding queues, 'text/plain' caps
everywhere but nothing changed.
Moreover, at the end the process blocks (on the last subtitle) and doesn't
free the pipeline.

Is there anyone that experienced the same kind of problems? Thank you very


View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list