RTSP server using v4l2src

yusuf.husainy yusuf.husainy at gmail.com
Wed Apr 10 05:11:21 PDT 2013

Hello everyone,

I am using the test-video.c for the server code but using v4l2src instead of
videotestsrc. The pipeline for the server is:

v4l2src device=/dev/video0 ! video/x-raw-yuv, width=800, height=600,
framerate=30/1 ! x264enc ! rtph264pay name=pay0 pt=96.

at the client, I am using VLC player to live stream.

when running the following command in terminal using above pipeline at
server, I got errors.

$ vlc rtsp://
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x9bae908] main libvlc: Running vlc with the default interface. Use 'cvlc'
to use vlc without interface.
[0xb4e03f88] live555 demux error: Failed to connect with
[0xb4e00618] main input error: open of `rtsp://'

when I use videotestsrc as my pipeline raw video source instead of v4l2src,
I got no error and the streaming starts flawlessly. I can view the test
video pattern generated by videotestsrc on my client using VLC with the same
command as above.

I cant figure out why v4l2src is not working with RTSP server???

I even tried using ffenc_mpeg4 and rtpmp4vpay instead of x264enc and
rtph264enc, but the same error occurs, I cannot connect to the server using
v4l2src, but videotestsrc has no problem at all, I can connect and also view
the test pattern.

I appreciate any suggestion or solutions.

Yusuf Husainy.

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/RTSP-server-using-v4l2src-tp4659459.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list