RTSP server using gstreamer-1.0 errors.

yusuf.husainy yusuf.husainy at gmail.com
Mon Apr 22 01:04:50 PDT 2013

Hi Robert,

Thanks for the help.

I tried what you suggested, but still the error remains the same.

name=pay0/Pay0 does not make any difference because, the client still can;t
get the sdp information from the server. The connection was made, but the
client can't make out the type of media.

However, if i try with videotestsrc, it work perfectly:
videotestsrc ! video/x-raw. width=800,height=600,franerate=30/1 !
avenc_mpeg4 ! rtpmp4vpay pt=96 name=pay0
rtspsrc location=rtsp:// latency =100 ! rtpmp4vdepay !
avdec_mpeg4 ! xvimagesink

The above two pipelines were also tried using v4l2src for my inbuilt laptop
webcam. with device=/dev/video1

However, it does not work with uvch264src with device=/dev/video0
auto-start-true. I am using C920 and want the H/W+ encoded h264 output from
uvch264src to be streamed from the server.

View this message in context: http://gstreamer-devel.966125.n4.nabble.com/RTSP-server-using-gstreamer-1-0-errors-tp4659557p4659577.html
Sent from the GStreamer-devel mailing list archive at Nabble.com.

More information about the gstreamer-devel mailing list