playbin : no mp4 sound

Otwoh a.guiavarch at
Wed Jul 3 08:43:09 PDT 2013

Thank you. 
But I've already tried to use qtmutex and avimutex.
Furthermore, there are no problem with the video part.

My problem is  only due to the MPEG-AAC codec. 
If I use component that automatically select  the good decoder, like
playbin2 or decodebin2, the video is played without sound.

When I tried to force the decoder with "ffdec_aac", the pipeline link fail.
Same error append with a simple "audioconvert".

I also tried to extract audio, with this pipeline : filesrc
location=test.mp4 ! qtdemux name=demux demux.audio_00 ! filesink
but the result file cannot be read. (The header is probably wrong, because I
write directly the audio buffer, without reencoding it)

I Can't find any comparable problem on the web...

PS : I'm on windows, so my version of Gstreamer (0.10.6) does not contain
all plugin. So I don't have faad to decode aac, just ffmpeg. 

View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list