Audio streaming via UDP

Pablo RL pabloxrl at
Tue Jul 9 02:57:14 PDT 2013

Hi David, thanks for your answer.

I'm trying with gst_parse_launch as well with the same result. However my
investigations have found out that I may be unable to open a raw socket
because of some limitation/rule in my firewall/network.

I'm able to stream UDP from Linux to W7, but the opposite doesn't work.
Seems that this issue may fall in the side of the OS.

I'll keep the thread updated with further findings.


On Mon, Jul 8, 2013 at 5:45 PM, David Röthlisberger <david at>wrote:

> On 8 Jul 2013, at 15:42, pablorl wrote:
> > Using gst-launch I'm able to get it using: gst-launch-1.0 filesrc
> > location=video.mp4 ! qtdemux ! udpsink host=localhost port=1234
> >
> > However I'm not able to achieve the same result through code although I
> > build the same pipeline.
> Does it work if you use "gst_parse_launch"?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list