[uvch264src in] "Got data flow before segment event" warnings until crash

Peter Rennert p.rennert at cs.ucl.ac.uk
Tue Jul 23 14:46:41 PDT 2013

I tried today to have another look at the issue.  I sent an email to Youness (the developer of the 0.10 version) and he came back to me yesterday, saying that neither he nor the  person who ported it to 1.0 has a camera to test. So the problem will not get fixed "automatically". But he thinks that there is an issue with the negotiation. And it should not be a big deal. I have no idea how Gstreamer works internally, but I would like to give it a shot. 

I was also thinking about reasons why it always and consistently fails after 35sec. I have the suspicion that the camera sends at that time a keyframe. And that crashes the pipeline somehow. That might also be something that is different to MJPEG encoding which probably does not fail.

I tried to confirm this, but I had problems to make uvch264src running in my (python) pipeline that I wanted to use for this simple testing. I will come  back to this tomorrow. Stay tuned.

krakorar <rob.krakora at messagenetsystems.com> wrote:
>Oops...had a type-o in the gst-launch-1.0 line...it still streams for
>35 seconds and then this happens:
>ERROR: from element
>Not enough data to read marker content
>Additional debug info:
>gstuvch264_mjpgdemux.c(507): gst_uvc_h264_mjpg_demux_chain ():
>View this message in context:
>Sent from the GStreamer-devel mailing list archive at Nabble.com.
>gstreamer-devel mailing list
>gstreamer-devel at lists.freedesktop.org

Sent from my Android device with K-9 Mail. Please excuse my brevity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20130723/887f02e1/attachment.html>

More information about the gstreamer-devel mailing list