Play h264 rtsp netstream with Gstreamer

liuxing gavinsperation at
Wed Jul 31 22:45:00 PDT 2013



         I am now trying to develop a small app to play the H264-encoded
network stream.

         I have tried to play the video stream using "play-launch rtspsrc
location=://.. ! rtph264depay ! avdec_h264 ! xvimagesink", and it works very

         When I write the C program , I put all the above elements in a
pipeline, and linked them all together. Besides, I catch the "pad-added"
signal and link the source pad of rtspsrc with sink pad of the h264depay.
Everything seems just like the command I have used above. However, when I
try to run the program, I got the "Error: internal data flow error ". Then I
tried to set the pipeline clock, but the error is still there.

         Can anyone give me some help on this? 

         Thinks very much!!


With Regards



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list