having problem with mp4mux

Sebastian Dröge sebastian at centricular.com
Tue Apr 8 23:22:50 PDT 2014

On Mo, 2014-04-07 at 14:20 +0200, Lajos Okos wrote:
> Dear Sebastian,
> I tried to run the same python code on a linux box and I made some
> progress. On Linux I can set the faststart property of the multiplexer in
> the encoderbin to True. In this case the code generates a valid mp4 file,
> with a moov atom right after the ftyp atom at the begining of the file as
> expected. On the other hand if I set the faststart property to False I have
> the same result as on windows. The mdat atom has an invalid size at byte
> offset 32.

Setting faststart to true on Windows does not help either?

Can you provide your sample code to reproduce this problem, either here
or in a bug report? Also which versions of GStreamer and the plugins are
you using?

Sebastian Dröge, Centricular Ltd - http://www.centricular.com
Expertise, Straight from the Source
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 949 bytes
Desc: This is a digitally signed message part
URL: <http://lists.freedesktop.org/archives/gstreamer-devel/attachments/20140409/740269db/attachment.sig>

More information about the gstreamer-devel mailing list