Streaming Mp4 file using Gstreamer

Gokul Vellingiri vgokul129 at
Fri Dec 19 06:28:18 PST 2014

I tried the following pipeline to stream mp4 file from my server side(Ubuntu
Command line-->which enable my server to stream video) and captures in
client side(Same machine,seperate command line).I successfully got the
stream for mp4 file(Codec Type:-Mpeg-4 video).But when i tried to play
another mp4 video(Type:-H.264 / AVC) is not playing.

*MP4 working:*


gst-launch-0.10 -v filesrc  location=/home/gokul/Videos/Tamil/Minvettu\
Naalil\ BRrip\ -\ Ethir\ Neechal\ HD.mp4 ! qtdemux name=d ! queue !
rtpmp4vpay ! udpsink host= port=5000


 gst-launch-0.10 udpsrc port=5000 caps = "application/x-rtp,
media=(string)video, clock-rate=(int)90000, encoding-name=(string)MP4V-ES,
payload=(int)96, ssrc=(uint)277375570, clock-base=(uint)627636935,
seqnum-base=(uint)55817" ! rtpmp4vdepay ! ffdec_mpeg4 ! xvimagesink

*MP4 not working


gst-launch-0.10 -v filesrc  location=/home/gokul/Videos/Tamil/Mun\ Andhi.mp4
! qtdemux name=d ! queue ! rtpmp4vpay ! udpsink host= port=5000
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
ERROR: from element /GstPipeline:pipeline0/GstQTDemux:d: GStreamer
encountered a general stream error.
Additional debug info:
qtdemux.c(3891): gst_qtdemux_loop (): /GstPipeline:pipeline0/GstQTDemux:d:
streaming stopped, reason not-linked
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
/GstPipeline:pipeline0/GstQTDemux:d.GstPad:audio_00: caps = NULL
/GstPipeline:pipeline0/GstQTDemux:d.GstPad:video_00: caps = NULL
Freeing pipeline ...

I'm using Ubuntu-12.04 and gstreamer-0.10

I don't know the exact pipeline which suits for Streaming Mp4(Codec
Type:H264/AVC) in server side

View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list