play rtsp camera(etrovision) with playbin2 - ubuntu 12.4

maorver maorver at
Tue Dec 23 03:31:49 PST 2014

Hi all

i trying  to play rtsp media  as client from rtsp camera server.

my os is ubuntu 12.4 (x86)

when i run those commands:
1 - with playbin :
gst-launch-0.10 -v playbin  uri=rtsp://
2- with pure gst-launch
gst-launch  rtspsrc location=rtsp://root:pass@ 
! decodebin !  autovideosink &

the results are ok and i can see the camera display.

 but when i run this commands for playbin2:
gst-launch-0.10 -v playbin2  uri=rtsp://
i cannot see anything and its seems from the logs that the rtsp packet is
arrive but my client (playbin2)
is stuck.
(attach log Ubuntu_playbin2_camera.txt) Ubuntu_playbin2_camera.txt

i must use  playbin2 because i have aboard (arm) that using qt that using
that playbin2 element also.
(From my test i see also that any other rtsp source is working well  with
playbin2 as client)

does anyone also encounter that kind of problem with playbin2 and rtsp from
ip camera ?

View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list