gstreamer not finding plugins in Windows

Eugen Dedu Eugen.Dedu at
Wed Feb 5 18:10:29 CET 2014

It turns out that this allowed me to solve the issue, so thank you!

The official bundle worked on my machine, showing many plugins.  After 
several tests I finally discovered that the problem was that in my 
installer I put bin/libgstapp-1.0-0.dll only, whereas lib/libgstapp.dll 
must be added too!!!

I have not noticed there are two files with similar names.  What is the 
difference between the two??

Also, I noticed that if libgstreamer...dll is in bin directory, plugins 
are searched in ../lib.  Otherwise, plugins are NOT searched in ../lib, 
but in ./lib. 
( shows 
only ../lib)

On 03/02/14 11:33, Rick Thomson wrote:
> Have you tried installing the prebuilt windows binary package and seeing if that works, that way you'll be able to compare the contents of the prebuilt package and the paths it sets up with what you've got.
> Won't help if the problem is with your built binaries, but at least you'll be able to narrow down any other issues.
> Rick
> -----Original Message-----
> From: gstreamer-devel-bounces at [mailto:gstreamer-devel-bounces at] On Behalf Of Eugen Dedu
> Sent: 31 January 2014 16:28
> To: Discussion of the development of and with GStreamer
> Subject: Re: gstreamer not finding plugins in Windows
> On 31/01/14 09:46, Eugen Dedu wrote:
>> On 30/01/14 13:05, Josh Doe wrote:
>>> On Wed, Jan 29, 2014 at 6:23 PM, Eugen Dedu
>>> <Eugen.Dedu at> wrote:
>>>> Hi all,
>>>> I need gstreamer and its plugins for Windows.  I cross-built with
>>>> mingw-w64
>>>> gstreamer and gst-plugins-base.  I copied libgstapp-1.0-0.dll,
>>>> libgstbase-1.0-0.dll and libgstreamer-1.0-0.dll and other libraries
>>>> and my .exe to the Windows machine, but I have errors with gstreamer
>>>> not finding some plugin.
>>> I've never cross compiled, but my guess is a library dependency issue.
>>> Are there really no errors from gst-inspect? Try increasing debugging
>>> with GST_DEBUG=*:3 or so. Also try running Dependency Walker.
> I obtained more information about the problem.  I execute gst-inspect... -gst-debug=*:5 and I obtain the following error:
> attempt to load plugin "...libgstapp..."
> Could not find plugin entry point in ...libgstapp...
> so the plugin is found, but there is an error when loading it.
> I looked in the code and found that the error is because a symbol is not
> found:
>     ret = g_module_symbol (module, "gst_plugin_desc", &ptr);
>     if (!ret) {
>       GST_DEBUG ("Could not find plugin entry point in \"%s\"", filename);
> However, grep shows:
> snoopy:~/softs/ekiga$ grep -r gst_plugin_desc gst-plugins-base-1.2.2/ Binary file gst-plugins-base-1.2.2/gst/app/.libs/libgstapp.dll matches Binary file gst-plugins-base-1.2.2/gst/app/.libs/libgstapp_la-gstapp.o
> matches
> gst-plugins-base-1.2.2/gst/app/.libs/libgstapp.dll.def:gst_plugin_desc DATA gst-plugins-base-1.2.2/gst/app/.libs/libgstapp.exp:gst_plugin_desc DATA [...]
> so I am lost on what could be wrong here.
> Can someone help here?

More information about the gstreamer-devel mailing list