timeout not working

Tim Müller tim at centricular.com
Sun Feb 23 09:06:16 PST 2014

On Sun, 2014-02-23 at 08:05 -0800, oguime wrote:


> Tried the workaround you suggested by sending an eos to matroskamux and it
> worked:
> Should I be concerned about not using the eos through the pipeline?

Well, I think it's a bug somewhere (possibly fixed in git master), but
no reason to be concerned I think.

>  Could there be any collateral effect?

The only side effect of sending the EOS directly to matroskamux is that
you're not draining any video data that may still be stuck inside the
encoder element (which could be a couple of seconds in the worst case).
You could try sending it to the encoder element instead.

> Would you have any hint on the X11 warnings?

No, sorry. I don't think this has anything to do with any of the
problems though.

You could run your application in gdb like this:

 $ G_DEBUG=fatal_warnings gdb --args python yourapp.py

(then type 'run', then wait for it to break at the warning, then type
'bt' to see where it comes from. Exit with 'quit' and kill).


Tim Müller, Centricular Ltd - http://www.centricular.com

More information about the gstreamer-devel mailing list