multiple stream throught videomixer + rtmpsink getting freeze

Weavel weavel37 at
Tue Jun 3 08:50:54 PDT 2014

Hey guys,

I'm working on a project which consist in sending a stream containing
multiple stream. For that purpose i use videomixer.
I'm using Gstreamer-1.2.3 working under debian gnome 3.4.2. I'm only testing
with video for the moment.

GST_DEBUG=4 gst-launch-1.0 videomixer sink_1::xpos=50 sink_1::ypos=50
name=mix ! videoconvert ! video/x-raw, height=1080, width=1920 ! x264enc
tune=zerolatency bitrate=2000 ! flvmux ! rtmpsink
location=rtmp://  rtmpsrc name=src1
location=rtmp:// ! decodebin ! mix.sink_0 rtmpsrc
name=src2 location=rtmp:// ! decodebin !

gst-launch-1.0 filesrc location=/home/user/Desktop/test1.mp4 ! videoconvert
! x264enc bitrate=1000 tune=zerolatency ! flvmux name=mux ! rtmpsink

gst-launch-1.0 filesrc location=/home/user/Desktop/test2.mp4 ! decodebin
name=dec ! x264enc bitrate=1000 tune=zerolatency ! mux. dec. ! audioconvert
! audioresample ! mux. flvmux name=mux ! rtmpsink

The source1 and source2 are working perfectly, but when mix together, i get
"freeze" about every 10sec during few seconds. I've tried to put multiqueue,
or to put do-timestamp to apply current stream time but no success.
I even tried to add the audio into a adder element and then linking it to
flvmux (because maybe without audio it couldn't synchronised correctly) so I
get sounds and videos, but i still got the freezing

I've checked my CPU and my connection and it all seems good.

Is this AV sync problem ? Can someone help me to find out where is the
problem please? 

Thanks in advance,
Regards, Weavel

View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list