Issue setting caps with 1.5.1

Sebastian Dröge sebastian at
Fri Jun 12 13:07:45 PDT 2015

On Fr, 2015-06-12 at 17:48 +0000, Matt Zawojski wrote:
> Hi,
> I have been developing my application with the 1.4.5 Windows build of 
> gstreamer.  With the recent release of the Windows binaries for 1.5.1 
> I thought I would give them a try.
> Using the 1.5.1 version I am running into an issue setting the caps 
> on an appsrc.  I am using the same code, just swapping between 
> gstreamer versions.  It works on 1.4.5, but does not on 1.5.1.  Below 
> is the GST_DEBUG output that I am seeing from each:
> [...]
> With version 1.4.5 things carry on from there, the pipeline goes to 
> the Playing state and all works well.  With version 1.5.1 you can see 
> that "gst_app_src_internal_get_caps" returns NULL and nothing ever 
> happens with the decodebin.  My pipeline stays in the CHANGE_ASYNC 
> state and I'm stuck.
> Cutting my code down to the pertinent lines, I am setting the caps 
> like so:
> const std::string AudioCaps::m_Capabilities_gsm = "audio/ms-gsm, 
> rate=8000, channels=1";
> GstCaps * m_GSMCaps = 
> gst_caps_from_string(m_Capabilities_gsm.c_str());
> g_object_set(m_AppSrc, "caps", m_GSMCaps, NULL);
> Has something changed between versions as far as how caps need to be 
> set for an appsrc?  I tried looking at the git commit log for appsrc 
> and gstcaps, but nothing stood out to me.  Anyone have any ideas?

Can you report a bug in Bugzilla at against
GStreamer and provide a standalone testcase there? There were some
changes in the caps handling of appsrc, but all those changes are
supposed to be backwards compatible. What worked in 1.4 has to still
work in 1.5/1.6, otherwise that's a bug.

Sebastian Dröge, Centricular Ltd ·
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 949 bytes
Desc: This is a digitally signed message part
URL: <>

More information about the gstreamer-devel mailing list