Gstreamer dependencies with glib, libc and any other new or old libraries

DeepakRohan deepak027rohan077 at
Fri May 19 09:55:10 UTC 2017

Hi All,

I have a question.

Suppose if I select a particular gstreamer version say 1.6 for my gstreamer
application development.

I know that the future/latest releases will have few fixes for other
plugins. So using gstreamer-1.6 will have issues which would have been fixed
in future releases.
Other than that if I need to do a project with glib and libc versions
different than the currently used in gstreamer 1.6 (may be below or above
also). Say current gstreamer-1.6 uses glib >= 2.4 (this is just an example
if I am wrong regarding the version), then can I do projects with glib
versions 2.0, 2.2, 2.6, 2.8 and so on without any issues..

Will there be any dependency that I have to take care during the project.

Also please share the problems that I may face and have to take care of them
during the project, if at all it can be done.

The above thought is just for the case where I do not want to update
gstreamer versions and dependencies and continue to develop on the gstreamer
version as selected at the beginning.

Also let me know if the above idea is really possible.

Thanks in Advance

View this message in context:
Sent from the GStreamer-devel mailing list archive at

More information about the gstreamer-devel mailing list