Pushing H265 encoded RTSP stream to wowza server

justin junione1997 at gmail.com
Thu Nov 29 02:00:00 UTC 2018

Dear all,

I hope anyone can shed some light on this please.
I am trying to push H265 encoded RTSP stream to wowza server. 
The reason why I am pushing the stream is because the video stream will be
transmitted by a 4G modem which has dynamic IP and hence pulling is not
Initially I have tried using RTMP however I decided to go with RTSP because
1. FLV does not support h265 2. Latency is too big for our application (need
smallest latency possible).

Moving forward, I have successfully implemented H264 encoded RTSP stream
push using the below pipeline.

gst-launch-1.0 v4l2src device="/dev/video0" ! 'video/x-raw,
width=1920,height=1080, framerate=30/1' ! videoconvert ! x264enc
speed-preset=superfast tune=zerolatency ! rtspclientsink location=rtsp://URL
protocols="tcp" latency=100 rtx-time=0 timeout=0 -v

This works well and the latency is pretty good too (0.5 seconds) however we
ideally need to use H265 to minimise the transmission bandwidth as the
network is restricted by the mobile dongle.

I have used below pipeline for H265 implementation - no errors are
displaying upon execution however I cannot play back the video using VLC or
/usr/bin/gst-launch-1.0 v4l2src device="/dev/video0" !
'video/x-raw,width=1920,height=1080,framerate=30/1,format=I420' ! x265enc
tune=zerolatency ! rtspclientsink
protocols="tcp" latency=100 rtx-time=0 timeout=0 -v*

also, is rtspclientsink only available in tcp protocol mode? I tried to
specify protocol as 'udp' as well as not specifying it at all, but it only
would work when specify it as tcp.

Any help would be greatly appreciated!

Sent from: http://gstreamer-devel.966125.n4.nabble.com/

More information about the gstreamer-devel mailing list