Wasapisrc dropping samples even when queue has leaky=downstream

Michael MacIntosh mmacintosh at linear-systems.com
Tue Mar 26 23:28:34 UTC 2019

Are you getting silence at all when this is happening?  Or is it not 

I ran into an issue with 14.4 where wasapisrc would play silence after a 
period of time.  The issue was potentially related to the internal audio 

This is the bugzilla ticket I created on it:


I eventually just worked around it by using directsoundsrc instead.  
With buffer time set to 200000 and latency time to 50000, to avoid 
similar issues with that element (they manifest after 10 minutes to 12 
hours).  Unfortunately you can't do that with wasapisrc because it 
auto-calculates the latency.

On 3/26/2019 3:15 PM, Marcos Kintschner wrote:
> So I have a pipeline with:
> wasapisrc low-latency=true ! queue leaky=2 ! ...
> And I get the following error from time to time:
> 0:00:39.224220600  8420   06A107D8 WARN            audiobasesrc
> gstaudiobasesrc.c:840:gst_audio_base_src_create:<audiosrc> create DISCONT of
> 320 samples at sample 508160
> 0:00:39.224331800  8420   06A107D8 WARN            audiobasesrc
> gstaudiobasesrc.c:845:gst_audio_base_src_create:<audiosrc> warning: Can't
> record audio fast enough
> 0:00:39.224397400  8420   06A107D8 WARN            audiobasesrc
> gstaudiobasesrc.c:845:gst_audio_base_src_create:<audiosrc> warning: Dropped
> 320 samples. This is most likely because downstream can't keep up and is
> consuming samples too slowly.
> It doesn't seem that the downstream elements are causing it since the queue
> has leaky=downstream and the overrun signal is never emitted anyway. What
> might be the cause?
> PS: Tested on Windows 10, GStreamer 1.15.2 x86 mingw
> --
> Sent from: http://gstreamer-devel.966125.n4.nabble.com/
> _______________________________________________
> gstreamer-devel mailing list
> gstreamer-devel at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel

More information about the gstreamer-devel mailing list