ModuleNotFoundError: No module named 'gi'

Nynke nynke.van.der.heide at
Wed May 1 08:15:47 UTC 2019

Hello everyone,

I'm new to Gstreamer and currently I get a ModuleNotFoundError.

When I run my script I get this stack trace:

Traceback (most recent call last):
  File "D:/x/x/x/x/", line 9, in <module>
    import gi
ModuleNotFoundError: No module named 'gi'

I'm using Windows 10, PyCharm Community Edition 2019.1.1 and Python 3.7.3.

I've tried the following to resolve the error:

- pip install pygobject --> ERROR: Command "'d:\program
files\python37\python.exe' 'd:\program files\python37\lib\site-packages\pip'
install --ignore-installed --no-user --prefix
--no-warn-script-location --no-binary :none: --only-binary :none: -i -- setuptools wheel pycairo" failed with error code
1 in None
(pycairo is already installed)

- I ran the msys2 installer ( and followed the
instructions on PyGObject read the docs

- I ran the PyGobject for Windows installer

Has anybody have had the same problem and was able to resolve it? I've been
on it for days but I seem not to be able to solve the problem.

Thank you very much,


Sent from:

More information about the gstreamer-devel mailing list