Problem playing RTP stream

Nik Ivanov 2centnik at
Thu May 16 00:12:47 UTC 2019

Hi everyone,

I'm running Janus webrtc server on a Raspberry Pi and forwarding RTP data
to UDP sockets where it is picked up by GStreamer and played via Alsa. I
had this solution running on a Raspberry Pi Zero W with no issues, but it
lacked computing resources so I upgraded to Raspberry Pi 3A+. For some
reason, I can't get audio from the browser to play locally on RPi 3A+with
the same solution as the one that worked on RPi Zero. Here's my GStreamer

gst-launch-1.0 -vvv  \
rtpbin name=rtpbin latency=100 \
udpsrc port=50000 caps="application/x-rtp, media=audio, encoding-name=OPUS,
clock-rate=48000" ! rtpbin.recv_rtp_sink_0 \
udpsrc port=50001 caps="application/x-rtcp" ! rtpbin.recv_rtcp_sink_0 \
rtpbin. ! rtpopusdepay ! opusdec !  audioconvert ! audiorate !
audioresample ! alsasink

I tried putting a filesink instead of rtpopusdepay and I'm definitely
receiving bytes. I'm not sure how to parse them for any meaningful info,
but here's a link:

Any suggestions are welcome! I've been banging my head against this problem
for a while. It's especially frustrating since I had it working on a
comparable piece of hardware before.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list