Pnmdec causes Internal data stream error

Valerymagadeeva v.magadeeva at
Fri Aug 14 12:44:38 UTC 2020

Every time I run my pipeline, it goes for a while, and then eventually
crashes with, "streaming stopped, reason error (-5).

0:00:00.383847433  8025 0x55cb237fe940 DEBUG                basesrc
gstbasesrc.c:2460:gst_base_src_get_range:<fdsrc0> calling create offset
5821984 length 4096, time 0
0:00:00.401808796  8025 0x55cb237fe940 DEBUG                basesrc
gstbasesrc.c:2315:gst_base_src_do_sync:<fdsrc0> no sync needed
0:00:00.401819755  8025 0x55cb237fe940 DEBUG                basesrc
gstbasesrc.c:2524:gst_base_src_get_range:<fdsrc0> buffer ok
0:00:00.401824818  8025 0x55cb237fe940 INFO                 basesrc
gstbasesrc.c:2860:gst_base_src_loop:<fdsrc0> pausing after gst_pad_push() =
0:00:00.401828989  8025 0x55cb237fe940 DEBUG                basesrc
gstbasesrc.c:2903:gst_base_src_loop:<fdsrc0> pausing task, reason error
0:00:00.401834372  8025 0x55cb237fe940 WARN                 basesrc
gstbasesrc.c:2950:gst_base_src_loop:<fdsrc0> error: Internal data stream
0:00:00.401837214  8025 0x55cb237fe940 WARN                 basesrc
gstbasesrc.c:2950:gst_base_src_loop:<fdsrc0> error: streaming stopped,
reason error (-5)

*My full pipeline:*

'rtpbin', 'name=rtpbin', 'rtp-profile=avpf',
'!', 'image/x-portable-pixmap,width=1280,height=720,framerate=30/1',
'!', 'pnmdec',
'!', 'queue',
'!', 'videoconvert',
'!', 'x264enc', 'tune=zerolatency', 'speed-preset=1', 'dct8x8=true',
'quantizer=23', 'pass=qual',
'!', 'video/x-h264, profile=baseline',
'!', 'rtph264pay', 'ssrc=111110', 'pt=96',
'!', 'rtprtxqueue', 'max-size-time=2000', 'max-size-packets=0',
'!', 'rtpbin.send_rtp_sink_0',
'!', 'udpsink', 'bind-address=', 'host=',
'bind-port=5004', `port=${videoRtpPort}`,
'!', 'udpsink', 'bind-address=', 'host=',
`port=${videoRtcpPort}`, 'sync=false', 'async=false', 'udpsrc', 'port=5005',
'!', 'rtpbin.recv_rtcp_sink_0', 

Seems that the problem is caused by pnmdec plugin. The following pipeline
throws the same error:

'fdsrc', 'fd=0',
'!', 'queue',
'!', 'image/x-portable-pixmap,width=1280,height=720,framerate=20/1',
'!', 'pnmdec',
'!', 'fakesink', 'dump=true',

But the pipeline without pnmdec works fine. Any thoughts about the issue?

*One more interesting thing*: I've noticed that the pipeline crashes after
the following event:

GST_SCHEDULING gstpad.c:4329:gst_pad_chain_data_unchecked:<pnmdec0:sink>[00m
called chainfunction &gst_video_decoder_chain with buffer 0x7f97c8310d80,
returned error

Sent from:

More information about the gstreamer-devel mailing list