Python Appsrc Internal data stream error

Yaro Kifor yarokifor at
Fri Aug 21 15:06:11 UTC 2020


I am working on a gstreamer project in python. I am using appsrc to push buffers to my pipeline. When I run my application my gtksink appears but a black void is displayed. I checked to make sure appsrc is pushing buffers, but when it does the debugging logs show "error: Internal data stream error" and "error: streaming stopped, reason not-negotiated (-4)". I looked into this and saw it could be something with my appsrc's caps, but I am very sure they are correct. However I still could be setting them incorrectly.

I am using Python 3.8.2 on Pop!_OS 20.04 LTS (Basically Ubuntu 20.04). I've tried pushing buffers filled with random data and still no luck.

My python script:

Please let me know if there's any more information I could provide. Also note I haven't implement exiting the application properly just yet.

Any help or guidance would be greatly appreciated. I am sorry if this mailing list isn't the correct place to ask for help. If there's a better place please let me know!

Thank you for reading this,
Yaro Kifor
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list