webrtcdsp and webrtcechoprobe on Windows

Attila kocsisa01 at gmail.com
Wed Jun 24 00:16:06 UTC 2020

I've tried setting the latency-time to a value lower than the buffer-time.
There's a small improvement, but the problem with the ringing persists.

I've recorded the result and shared the file (echo.mp3) on my google drive:

To make it work, I had to increase the buffer-time on both the source and
the sink. I've also tried adjusting the noise-suppression-level and
echo-suppression-level, but setting them both to high seems to give the best
result (no change).

After some testing, the pipeline below seems to give the best result.

gst-launch-1.0 -v -e wasapisrc buffer-time=600000 ! audioconvert !
audio/x-raw, layout=non-interleaved ! webrtcdsp noise-suppression-level=high
echo-suppression-level=high ! audioconvert ! webrtcechoprobe ! audioconvert
! wasapisink buffer-time=20000 latency-time=15000  


At this point, I'm wondering how I should proceed... I can't seem to get
this to a point where a 2-way conversation without headphones can be carried
out and it seems unlikely, that I can fix this by following up on short
hints (which are greatly appreciated!).

Is there a way to get someone to give me a little more hands on assistance?
If so, how should I go about that?
Am I even on the right track trying to do this with gstreamer? ...or should
I try coding this using the relevant libraries directly (clearly much more
work, but if it works better)?


Sent from: http://gstreamer-devel.966125.n4.nabble.com/

More information about the gstreamer-devel mailing list