how to enable gstreamer leaks tracker?

Jovic, Vladimir vladimir.jovic at
Thu Nov 26 14:25:48 UTC 2020


I tried modifying my program to end after some time and call gst_deinit(), but that didn't do anything. I still don't get any output.

Even gst-launch-1.0 is not doing anything:

root at pdm3:/home# GST_TRACERS="leaks"  GST_DEBUG="*TRACER:7" gst-launch-1.0 videotestsrc num-buffers=10 ! fakesink
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Got EOS from element "pipeline0".
Execution ended after 0:00:00.010384134
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
root at pdm3:/home#

I am having a custom linux image built with yocto, and it runs on arm.

I still don't get it, do I need to configure gstreamer to get the leak tracer?

From: Jovic, Vladimir
Sent: 26 November 2020 13:40
To: gstreamer-devel at
Subject: how to enable gstreamer leaks tracker?


I would like to track a leak in my application, which uses gstreamer libraries to display ip camera image.

Reading online documentation, I set next environment variables and then I run my program:


but it didn't print anything.

So, I was wondering - do I need to somehow configure gstreamer libraries to enable leaks tracer? I use yocto to build, and the version is 1.16.2.


Vladimir Jovic

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list