How to configure webrtc echo cancellation in Windows 10?

Maksim Danilov fblackmessms at
Wed Mar 24 06:49:02 UTC 2021

Thanks for the answer. I gave up on configuring AEC over rtp and came up with
simple example that look like:
wasapisrc ! audioconvert ! audio/x-raw, format=S16LE, rate=48000 !
audioconvert ! webrtcdsp ! webrtcechoprobe ! audioconvert ! wasapisink. 
It gives no result (in linux everything work as expected). 
I tried you suggestion with low-latency mode, however got messages with
'invalid latency add some queues to the pipeline'. Even if I add queue to
pipeline. I can't hear my self at all.
That pipeline gives the same result: wasapisrc low-latency=true ! <queue> !
wasapisink low-latency=true.
So I think the problem is in plugin. Probably it add some additional latency
in implementation, cause it doesn't act like real time.
I inspected the code of plugin and it looks like a very fast implementation
of api under Windows. Moreover it can't even capture specific caps of
src/sink and uses shared format F32LE (maybe it is resampling and converting
audio in core and we get some latency through).

Sent from:

More information about the gstreamer-devel mailing list