Appsrc doesn't play audio to autoaudiosink

Kyle Gibbons kyle at
Wed Nov 24 11:28:53 UTC 2021


Thanks for the reply, I hadn't thought of clock sync being the issue.

I had not tried provide-clock=false yet, I added that and it did not
produce audio.

When I run your test pipeline through gst-launch or when I run my pipeline
in the app sinking to pulsesink I am getting the below warning now:

0:00:10.029368286  6890 0x622ac030 WARN           audiobasesink
correct clock skew -0:00:00.020028565 < -+0:00:00.020000000

With your test pipeline I am getting a skip in the audio every time that
message displays. In my app, still no audio at all.

The audio is coming into the app via WebRTC using the Pion library for Go.
I believe I did try feeding raw audio into the pipeline from the app before
and that it did work, but that was while ago, I will test that again.

All the best,
Kyle Gibbons

On Wed, Nov 24, 2021 at 5:05 AM Nirbheek Chauhan <nirbheek.chauhan at>

> Hi Kyle,
> On Wed, Nov 24, 2021 at 6:15 AM Kyle Gibbons via gstreamer-devel
> <gstreamer-devel at> wrote:
> >
> > I'm having a problem with GStreamer with Pion and I'm hoping this group
> could point me in the right direction, I'm not really sure where to look
> next. I have been trying to troubleshoot this for a couple months now with
> no success. This week I realized that the same pipeline does work on my
> Mac, just no on the Raspberry Pi. Here's some details:
> >
> This smells like a clock sync issue. Have you tried pulsesink
> provide-clock=false already?
> How are you feeding data into the appsrc? It would be best if you
> could share a minimal test case for this. Also try feeding raw audio
> data into appsrc instead of opus.
> Does this pipeline work on the rpi?
> audiotestsrc is-live=true ! opusenc ! queue ! opusdec ! audioconvert !
> audioresample ! queue ! pulsesink
> Cheers,
> Nirbheek
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list