audiotestsrc vs. multifilesrc

Florian Echtler floe at
Thu Jan 13 10:22:02 UTC 2022

Hello everyone,

I'm having an issue here that's probably very simple, but I can't see what's wrong.

I've been using the following audio source for testing in my larger WebRTC pipeline:

audiotestsrc is-live=true wave=ticks ! 
audio/x-raw,format=S16LE,rate=48000,channels=1 ! tee allow-not-linked=true 

Now I've tried to replace it with an audiofile of a voice counting (to estimate 
delay etc.):

multifilesrc do-timestamp=true loop=true location=count.wav ! wavparse 
ignore-length=1 ! audio/x-raw,format=S16LE,rate=48000,channels=1 ! tee 
allow-not-linked=true name=audiotestsrc

The audiofile does have S16LE/48kHz/mono, so there shouldn't be any format 
issues. Both variants work when I run them in gst-launch-1.0 and append an 
autoaudiosink at the end; I can even replicate the encoder pipeline by appending 
"... ! queue ! opusenc ! rtpopuspay ! queue max-size-time=100000000 ! 
rtpopusdepay ! opusdec ! autoaudiosink" and it still works for both of them.

However, when I connect the encoder output to webrtcbin within my larger 
pipeline, then the multifilesrc seems to never start streaming. Caps negotiation 
and WebRTC SDP negotiation both complete and seem to be fine, but I'm never 
actually getting an audiostream unless I keep using audiotestsrc (or e.g. 
alsasrc/pulsesrc, those work as well).

For the curious, audiofile in question is here:

Any suggestions?

Thanks and best regards, Florian

-------------- next part --------------
A non-text attachment was scrubbed...
Name: OpenPGP_signature
Type: application/pgp-signature
Size: 203 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the gstreamer-devel mailing list