How to run with the specifically installed gstreamer version on Ubuntu?

cfd new newcfd at
Thu Apr 27 15:45:12 UTC 2023

 no help with
export GST_PLUGIN_PATH=/opt/gstreamer/lib/opt/gstreamer/bin/gst-inspect-1.0 -b shows libgstcodecs-1.0 is in the blacklist
Any help?
    On Thursday, April 27, 2023, 10:09:20 a.m. EDT, cfd new <newcfd at> wrote:  
 Hi, Guys,
   I installed gstreamer 1.22.4 under opt/gstreamer in Ubuntu 22.04 which has 1.20.3. Also libva and vaapi driver are built with it.They all are installed under the same dir  /opt/gstreamer. I set the following environment variables
export LD_LIBRARY_PATH=/opt/gstreamer/lib/:$LD_LIBRARY_PATHexport PATH=/opt/gstreamer/bin:$PATHWhen I tried to run a pipeline, I got the following messageWarning: erroneous pipeline: no element "vah264dec".vah264dec is in plugin-bad and it is definitely installed. 
but /opt/gstreamer/bin/gst-inspect-1.0 -b shows is in the blacklist/opt/gstreamer/bin/gst-inspect-1.0 vah264dec shows no such element or plugin "vah264dec"
I also tried to set 
export GST_PLUGIN_PATH==/opt/gstreamer/lib/gstreamer-1.0and removed cache file in ~/.cache/gstreamer
The result is same.
What else should I do to remove codecs from the blacklist and make it available?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the gstreamer-devel mailing list