<html><head></head><body><div style="color:#000; background-color:#fff; font-family:verdana, helvetica, sans-serif;font-size:16px"><div id="yui_3_16_0_ym19_1_1459943407114_212482">My knowledge about IP network is a little old but I will</div><div dir="ltr" id="yui_3_16_0_ym19_1_1459943407114_212498">give some suggestions.</div><div dir="ltr" id="yui_3_16_0_ym19_1_1459943407114_212568"><br></div><div dir="ltr" id="yui_3_16_0_ym19_1_1459943407114_212568">Your 2 devices are not in the same IP network(differents IP</div><div dir="ltr" id="yui_3_16_0_ym19_1_1459943407114_212568">address) do you have a router between them?</div><div class="signature" id="yui_3_16_0_ym19_1_1459943407114_211792"><div id="yui_3_16_0_ym19_1_1459943407114_211791"><div style="font-family:arial, helvetica, clean, sans-serif;" id="yui_3_16_0_ym19_1_1459943407114_212561"><span style="font-size:13px;"><br></span></div><div id="yui_3_16_0_ym19_1_1459943407114_212558"><br></div></div></div> <div class="qtdSeparateBR"><br><br></div><div class="yahoo_quoted" style="display: block;"> <div style="font-family: verdana, helvetica, sans-serif; font-size: 16px;"> <div style="font-family: HelveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif; font-size: 16px;"> <div dir="ltr"><font size="2" face="Arial"> Le Dimanche 10 avril 2016 15h27, Vassiliev <Valera.Vassiliev@gmail.com> a √©crit :<br></font></div>  <br><br> <div class="y_msg_container">Hello,<br><br>I am trying to send video stream from my Raspberry Pi to PC using UDP<br>protocol. RPi and PC connected to same Wi-FI network with static IP<br>77.87.xxx.xx<br><br>On RPi:<br>gst-launch-1.0 -v rpicamsrc preview=0 bitrate=1000000 ! video/x-h264,<br>width=1280, height=720, framerate=25/1, profile=high ! h264parse !<br>rtph264pay config-interval=1 pt=96 ! udpsink host=77.87.xxx.xx port=5000 <br><br>On PC:<br>gst-launch-1.0 -v udpsrc port=5000 ! application/x-rtp, encoding-name=H264,<br>payload=96 ! rtph264depay ! avdec_h264 ! autovideosink sync=false<br><br>Also on router (Zyxel Viva) I created a NAT rule:<br><<a href="http://gstreamer-devel.966125.n4.nabble.com/file/n4676807/nat.png" target="_blank">http://gstreamer-devel.966125.n4.nabble.com/file/n4676807/nat.png</a>> <br><br>With such setup I cant get anything, while with host=192.168.1.5 it works<br>correct.<br>Where is the problem?<br><br>Thanks<br><br><br><br>--<br>View this message in context: <a href="http://gstreamer-devel.966125.n4.nabble.com/UDP-connection-over-Internet-tp4676807.html" target="_blank">http://gstreamer-devel.966125.n4.nabble.com/UDP-connection-over-Internet-tp4676807.html</a><br>Sent from the GStreamer-devel mailing list archive at Nabble.com.<br>_______________________________________________<br>gstreamer-devel mailing list<br><a ymailto="mailto:gstreamer-devel@lists.freedesktop.org" href="mailto:gstreamer-devel@lists.freedesktop.org">gstreamer-devel@lists.freedesktop.org</a><br><a href="https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel" target="_blank">https://lists.freedesktop.org/mailman/listinfo/gstreamer-devel</a><br><br><br></div>  </div> </div>  </div></div></body></html>