[gst-embedded] gst-openmax 0.10.0.5 pre-release

Felipe Contreras felipe.contreras at gmail.com
Sun Apr 26 16:26:56 PDT 2009


Wrong log, this is the correct one:

Edward Hervey (2):
      autogen.sh : Use git submodule
      Install and use pre-commit indentation hook from common

Felipe Contreras (163):
      Go back to development.
      Cleanup the new volume element.
      Update library name to new bellagio library.
      Fix warnings.
      Check for NULL buffers when sending eos.
      Temporary disable buffer flushs.
      Use BufferCountActual instead of BufferCountMin.
      Allow AllocateBuffer.
      Random cleanups.
      Use G_UNLIKELY when finding the GType.
      Finish processing when receiving omx eos event.
      Cleanup pad_event in base_filter.
      Cleanup pad_event in base_sink.
      Rename port enable/disable to resume/pause.
      Add port allocate/free/start buffer functions.
      Add option to flush the async_queue.
      Store the port_index.
      Allow multiple setup_ports calls.
      Add port semaphore.
      Add port enable/disable functions.
      Flush the queue when disabling the port.
      Make port_enable more extensible.
      New omx interface.
      Add omx interface to base_sink.
      Add omx interface to base_filter.
      Add activate_push in base_sink.
      Save omx ports as element data of the gst pads.
      Make omx state changes more strict.
      Add core_for_each_port helper in util.
      Add flushing functions in util.
      Improve flushing in base_filter.
      More general improvements in flushing.
      Add separate mp2dec element.
      Free codec_data
      Add new jpegenc component wrapper.
      Allow child classes to override the share_output_buffer workaround.
      Improve message when the shared output buffer workaround is misbehaving.
      Improve error message when pusing output buffers.
      Properly set the true return reason.
      Set right caps for amrwbenc.
      Fix speech codecs samplerates.
      Fix warnings in jpegenc.
      Improve buffer sizes in jpegenc.
      Update ADPCM sample rate.
      Random cleanups.
      Add adpcm layout.
      Update G729 media-type.
      Use more efficient int scaler.
      Fix initialization of buffers for processing.
      Release output buffer when there's flushing.
      Cleanup flushing mechanism for seeking.
      Properly deinitialize when going to READY.
      Add new semaphore utility.
      Add stress unit tests for async_queue.
      Random cleanups.
      Improve internal libomxil unit tests.
      Improve debug logging for gstomx util.
      Fix EOS handling when omx hasn't been initialized.
      Improve G711 caps negotiation.
      Fix G711 decoder caps.
      Rename avcenc to h264enc.
      Fix iLBC caps negotiation.
      Fix seeking when using zero-copy.
      jpegenc: Add quality property.
      Allow child classes to override the share_input_buffer workaround.
      adpcm: Fix capabilities negotation.
      More specific caps for all audio elements.
      Random cleanups.
      Missing cleanups from old git repo.
      util: Fix for allocate buffer.
      Send initial codec_data buffer.
      sink: Cleanup element details.
      aacdec: Store codec-data.
      Remove TI-specific stuff.
      Fix crash on certain race condition.
      util: More debug logging.
      util: Make omx errors more verbose.
      basefilter: handle codec-data from omx
      Create .gitignore file
      Make libcheck optional
      Update copyright notice for 2009.
      Fix libcheck' check
      util: detect more unrecoverable errors
      check_gstomx: cleanup codes-tyle
      util: fix crash when OMX_Init errors
      util: cleanup request_imp
      Set more proper framerate in the caps templates
      video encoders: trivial cleanups
      General update to framerate handling
      basefilter: fix init race condition
      Cleanup global scope
      Trivial code-style cleanups
      Cleanup enums
      Remove automatic pre-commit hook
      Remove common submodule
      Some cleanups to the 'common' stuff
      Rename 'initialized' to 'ready'
      Cleanup .gitignore
      Even more framerate improvements
      videoenc: fix Q.16 framerate calculation
      Remove stdbool.h
      Use memset instead of calloc
      util: handle more errors from omx
      Trivial cleanups
      basefilter: trivial cleanup
      util: fix break statements in event_handler
      util: make OMX_AllocateBuffer configurable
      basefilter: plug a leak
      Add environment variables for testing
      util: avoid double-free
      jpegenc: fix quality setting
      plugin: refactor
      Replace dispose with finalize
      basesink,basesrc: fix library and component name
      basesink: chain up activatepush
      Add ignore files for 'tests' dir
      plugin: trivial whitespace fix
      g729enc: trivial cleanup for default DTX
      basefilter: appropriately return wrong state
      Revert "Do not hang in state change when flushing."
      Improve error handling
      util: add timeout to wait_for_state
      util: cleanup timeout stuff
      basefilter: trivial cleanup
      util: display error message sooner
      Remove unused variables
      Trivial cleanups
      test: fix gcc warnings
      util: remove g_omx_sem and use shared g_sem
      Cleanups
      Add shave build option
      Use 'git describe' for automatic version
      Move common stuff to build-aux
      configure.ac: cleanup
      .gitignore: cleanup
      Fix distribution
      git-version-gen: fix for old versions of git
      basesink: don't hang on downward state change
      basesink: move omx initalization to pad link
      basesink: add empty change_state function
      basesink: align gst and omx states in base_sink
      basesink: initalize omx when changing to READY
      Always check the omx state
      util: don't set artificial omx errors
      util: handle all errors
      base_filter: cleanup PAUSED_TO_READY
      util: nicer error messages
      Trivial cleanup; rename client_data field
      util: improve logging
      plugin: trivial cleanup
      plugin: trivial cleanup
      Add 'update-common' script
      build: improve version generation
      basefilter: cleanup
      Add core_stop function to split core_finish
      util: trivial rearrange
      Remove core_finish, use core_unload
      plugin: decrease priority of vorbisdec
      build: add enable-experimental option
      Remove ChangeLog
      autogen.sh: fix build and cleanups
      Add 'patches' directory to the dist
      Update README

Frederik Vernelen (2):
      Allow null buffers.
      Add new volume element.
      basesink: add NXP copyright

Jan Schmidt (1):
      configure.ac: trivial cleanup

Marco Ballesio (1):
      Properly calculate timestamps when input buffers are split

Mark Nauwelaerts (8):
      Do not hang in state change when flushing.
      Fix mt issue when loading/unloading omxil.
      Serialize EOS sending.
      Handle unrecoverable errors.
      Fix format specifier in debug statement.
      Fix race in test.
      g729enc: set caps on srcpad
      basefilter: don't start task when omx is not ready

Olivier Crête (1):
      g711enc: Only try to fetch structure from caps if it exists.

René Stadler (16):
      Forward pad event properly.
      amrnbenc: Add rate=8000 field to amr caps
      amrwbenc: Add rate=16000 field to amr caps
      Fix configure failing because of missing m4 directory.
      aacdec: Don't set the profile.
      Don't limit framerate to 30fps for video decoder pad templates.
      Pass on correct sink framerate fraction.
      aacenc: Fix src caps by not relying on settings_changed callback.
      Fix unused variables breaking the build.
      util: Fix crash when dlopen() fails.
      aacenc: Propagate bitrate property value to component.
      aacenc: Add output-format property, setting eAACStreamFormat.
      aacenc: Implement profile property.
      jpegenc: Forward upstream framerate in caps.
      basefilter: release ready_lock when core_prepare fails
      jpegenc: fix classification

Sriram Murthy (1):
      audio_sink: Set correct class.

Tim-Philipp Müller (1):
      .gitignore: ignore more

-- 
Felipe Contreras




More information about the Gstreamer-embedded mailing list