[Gstreamer-openmax] [PATCH] Add GSTOMX_BOILERPLATE macros

Rob Clark rob at ti.com
Sun Nov 22 21:35:39 PST 2009

On Nov 14, 2009, at 6:41 AM, Felipe Contreras wrote:

> On Wed, Nov 4, 2009 at 4:26 AM, Rob Clark <rob at ti.com> wrote:
>> These work like the GST_BOILERPLATE macros, but following the  
>> naming conventions for init functions used in the gst-openmax code,  
>> to remove a lot of gobject related boilerplate code.
> This seems ok, but I don't like the GSTOMX_BOILERPLATE_FULL; it's only
> used on the base classes which by architecture are always going to be
> few, and might even change quite drastically in the future (in order
> to do tunneling properly).

I initially started without the _FULL version of the macro.. but then  
decided that adding it let me remove a bunch of code from the base  
components, and was more closely aligned with the GST_BOILERPLATE*()  
macros (which seemed like a good thing)..

The _FULL() version of the macro allows for implementation of  
interfaces, and other such flexibility, so I would have thought that  
changes in base components to support tunneling, or other such  
enhancements could be accommodated by the _FULL() version of the  
macros.. but maybe you have something in mind?


More information about the Gstreamer-openmax mailing list