[Gstreamer-openmax] AV Sync with Gst-OpenMax pluggin

Tejas tejas at picus.in
Tue Mar 2 01:18:28 PST 2010

	I have installed totem latest version which is 2.28.5 and tried to
play VGA and HD video content. But still I am getting same kind of errors. I
can tell about my steps.

1.	My boot args are as followed.
	"setenv bootargs 'console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw
rootwait omapfb.mode=dvi:1280x720MR-32 at 60 vram=16M omapfb.vram=0:8M,1:8M'  "

2.	Boot system and open totem movie player, maximize it and try to play
640 x 480 VGA video content. It is playing properly. Now when I restore down
the totem window while my playback is going on only blue screen is running
and following error message is coming on my HyperTerminal window.
	"omapdss MANAGER error: dispc_setup_plane failed for ovl 1"

3.	The same thing happens for HD content having 1280x720. In this case
something different behavior. I open totem movie player, start 1280x720 HD
video content, only blue screen is running. Now when I do full screen actual
video is playing. And when I do leave full screen again blue video play back
is going on. And same error message is coming.

	Can anyone tell where I am lacking ? Is there any settings which I
forgot to make? Please guide me and correct me if I am wrong.


-----Original Message-----
From: Clark, Rob [mailto:rob at ti.com] 
Sent: Tuesday, February 23, 2010 8:30 PM
To: Tejas
Cc: Felipe Contreras; Stefan Kost; gstreamer-openmax at lists.sourceforge.net
Subject: Re: [Gstreamer-openmax] AV Sync with Gst-OpenMax pluggin

could you patch totem to use playbin2?  For most part, you just have to
replace "playbin" with "playbin2".

the native-video and native-audio flags on playbin2 result in a more
embedded friendly pipeline.. that alone is worth the switch


On Feb 22, 2010, at 11:10 PM, Tejas wrote:

> Hi Felipe,
> 	With help of playbin2 also I am able to run all HD video content by
following commands.
> $ gst-launch-0.10 playbin2 uri=file:///648x480.mp4
> $ gst-launch-0.10 playbin2 uri=file:///1280x720.mp4
> 	I have taken debug log of totem playback, it is  creating bin as
playbin only.
> totem --gst-debug=GST_ELEMENT_*:3 --play /media/mmcblk0p1/Movie.mp4
> 	It is using playbin only. And the kernel image which I am using is
having DSS2. 
> 	I have added "omapfb.vram=0:2M,1:4M" argument to my boot argument.
Still I am getting "omapdss MANAGER error: dispc_setup_plane failed for ovl
1" error
> -Tejas.
> -----Original Message-----
> From: Felipe Contreras [mailto:felipe.contreras at gmail.com] 
> Sent: Monday, February 22, 2010 5:39 PM
> To: Tejas
> Cc: Stefan Kost; gstreamer-openmax at lists.sourceforge.net
> Subject: Re: [Gstreamer-openmax] AV Sync with Gst-OpenMax pluggin
> On Mon, Feb 22, 2010 at 2:00 PM, Tejas <tejas at picus.in> wrote:
>> Hello Felipe,
>>       As I was not able to play any video content with the help of
omapfbsink plugin. Later I found that memory from frame buffer 1 was not
mapped , because memory for fb1 has not been allocated. After my system of
beagle board boots I am running following commands to allocate memory.
>>       My boot args is as followed.
>> "setenv bootargs 'console=ttyS2,115200n8 root=/dev/mmcblk0p2 rw rootwait
omapfb.mode=dvi:1280x720MR-32 at 60 vram=12M'"
> I add "omapfb.vram=0:2M,1:4M". I'm not sure if you need that in recent
>> $echo 8000000 > /sys/class/graphics/fb1/size
>> $fbset -fb /dev/fb1 -nonstd 1
>> $echo "1" > /sys/devices/platform/omapdss/overlay1/enabled
>> $echo "$1,$2" > /sys/devices/platform/omapdss/overlay1/output_size
>> $echo "0,0" > /sys/devices/platform/omapdss/overlay1/position
>> $fbset -fb /dev/fb0 -xres $1 -yres $2
>> $echo "0,0" > /sys/devices/platform/omapdss/overlay0/position
>> $echo "0" > /sys/devices/platform/omapdss/display0/enabled
>> $echo "" > /sys/devices/platform/omapdss/manager0/display
>> $echo "0" > /sys/devices/platform/omapdss/overlay1/enabled
>> $
>> $echo "1" > /sys/devices/platform/omapdss/overlay1/enabled
>> $echo "dvi" > /sys/devices/platform/omapdss/manager0/display
>> $echo "1" > /sys/devices/platform/omapdss/display0/enabled
>>       I put all these command into one disp.sh file and run it as
./disp.sh 640 480, then 640x480 display comes and rest comes as black. Now I
can run following command smoothly.
>> $gst-launch-0.10 playbin uri=file:///648x480.mp4
> AFAIK omapfbsink would do most of those sysctl commands. However maybe
> you are using and old version of gst-omapfb.
>>       After that when I run following command, that display doesn't come
properly. That video content is of resolution 1280 x 720.
>> $gst-launch-0.10 playbin uri=file:///1280x720.mp4
>>       After that I run ./disp.sh 1280 720 and then run above command I
can play video properly.
>>       But when I run 1280 x 720 video file into totem movie player
nothing is coming and only blue screen throught entire video play back.
After getting log file it gives following error.
>> "omapdss MANAGER error: dispc_setup_plane failed for ovl 1"
>>               Can any one guide me to come out this error.
> That's really strange. Totem shouldn't be doing anything different...
> well, I't using playbin2 instead of playbin. Can you try that?
> Anyway, I would add debugging in gst-omapfb to find out what
> parameters are being used to setup the plane that make it fail.
> Cheers.
> -- 
> Felipe Contreras
> Download Intel&#174; Parallel Studio Eval
> Try the new software tools for yourself. Speed compiling, find bugs
> proactively, and fine-tune applications for parallel performance.
> See why Intel Parallel Studio got high marks during beta.
> http://p.sf.net/sfu/intel-sw-dev
> _______________________________________________
> Gstreamer-openmax mailing list
> Gstreamer-openmax at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gstreamer-openmax

More information about the Gstreamer-openmax mailing list