camera.* attribute proposal

Jeffrey Stedfast fejj at novell.com
Wed Aug 31 13:36:37 PDT 2005


Since the camera.* attributes seem to not be terribly useful atm and are 
working at making my life more difficult, I'd like to propose something 
that would work for me and (I hope) everyone else.

Currently there is a camera.access_method which, afaict, can currently 
hold at least 2 values: 'ptp' and 'libgphoto2' where 'libgphoto2' 
incldues at least usb mass storage cameras and some proprietary protocols.

The 'ptp' access_method value is actually meaningful. It tells me that 
the camera supports the ptp protocol. Horrah for standards!

'libgphoto2' tells me that libgphoto2 can access it. whoopty-doo. 
libgphoto2 can work with ptp cameras, usb mass storage cameras and a 
variety of proprietary protocols. If you stop and think about this, it 
pretty much means there's no use for 'ptp'.

if you get rid of 'ptp' tho, then the value becomes totally useless. 
might as well be camera.libgphoto2_support = true / false, but that 
isn't all that useful either.

Now, here's what I propose:

I propose that access_method becomes what it suggests it means, the 
actual access_method: 'ptp' 'storage' 'proprietary' etc...
I also propose that camera.libgphoto2_support = true / false be present 
for those who all they care about is that.

this means we have basically 4 possible scenarios (unless we want to get 
even more specific about proprietary access_methods)

USB Mass Storage camera:
info.category = 'camera'
camera.access_method = 'storage'
camera.libgphoto2_support = 'true'

PTP camera:
info.category = 'camera'
camera.access_method = 'ptp'
camera.libgphoto2_support = 'true'

Proprietary access method camera with libgphoto2 support:
info.category = 'camera'
camera.access_method = 'proprietary'
camera.libgphoto2_support = 'true'

Proprietary access method camera without libgphoto2 support:
info.category = 'camera'
camera.access_method = 'proprietary'
camera.libgphoto2_support = 'false'


Of course, feel free to rename 'storage' and 'proprietary' to whatever 
you guys would prefer. And as I hinted at above, feel free to replace 
'proprietary' with actual proprietary protocol names if that's what 
you'd prefer to do (I think in the long run it'd be a nice addition but 
in the interest of "easy fix" 'proprietary' would satisfy me)

Is this doable?

Jeff


More information about the hal mailing list