hal 0.5.x segfaults, even after reinstall, though it worked in the beginning

Dennis Heuer dh at triple-media.com
Wed Jan 9 16:40:31 PST 2008

my previously working hal 0.5.9 installation seems to always segfault
at system startup. the crashing app is hal-probe-stor (read from the
boot log onscreen). this is interesting because i only recognized the
problem by accident (my system behaves normal, i think.) possibly it's
because i updated to linux 2.6.23 or so.

i installed 0.9.10 but it segfaults too. here is the line from the

hald[1504]: segfault at 00000000 eip 08062f7c esp bf93d7d0 error 4

i ran hald through gdb, like described in the docs, and here's the
output to the logfile (on screen there was a lot more noise but it
seemed to be only status info):

Starting program: /usr/sbin/hald --daemon=no --verbose=yes

Program received signal SIGSEGV, Segmentation fault.
0x08062f7c in ids_find_pci (vendor_id=4358, product_id=516, 
    subsys_vendor_id=4163, subsys_product_id=33065,
vendor_name=0xbf92cffc, product_name=0xbf92d000,
subsys_vendor_name=0xbf92d004, subsys_product_name=0xbf92d008) at
ids.c:82 82		for (i = 0;

can you make use of this. otherwise you'll have to instruct me. i'm no
good in debugging :(


More information about the hal mailing list