[HarfBuzz] harfbuzz-ng: Branch 'master'

Behdad Esfahbod behdad at kemper.freedesktop.org
Wed Oct 13 07:57:42 PDT 2010


 TODO |   72 ++++++++++++++++++++++++++++++++++++++++++++++++++++++-------------
 1 file changed, 59 insertions(+), 13 deletions(-)

New commits:
commit 04a3023a66203d94b77f2d7a8d6bcdedf067e155
Author: Behdad Esfahbod <behdad at behdad.org>
Date:   Wed Oct 13 10:57:27 2010 -0400

    Cleanup TODO
    
    Looks like a roadmap now.

diff --git a/TODO b/TODO
index 001f437..ffa83c8 100644
--- a/TODO
+++ b/TODO
@@ -1,23 +1,69 @@
+General fixes:
+=============
+
+- Fix feature mask bugs
+
+- Fix tt kern on/off
+
+- Remove hb_internal_glyph_info_t, etc
+
+- Remove synthesized GDEF
+
+- Use size_t in sanitize
+
+
+API issues to fix before 1.0:
+============================
+
+- Sprinkle const all over public and private API
+
 - Rename get_table to reference_table
 
-- Avoid allocating blob objects internally for for_data() faces
+- get_table shouldn't return NULL
 
-- head table access cleanup (div by zero now!)
-- cache various expensive scale computation
+- Use tags for hb_script_t?
 
-- SFNT api?  get_num_faces?
+- Future-proof metrics struct
 
-- GNOME Bug 612402 - (hb-arm) HarfBuzz compilation fix for arm
+- Figure out how many .so objects, how to link, etc
+
+
+API to add (maybe after 1.0):
+============================
+
+- Add hb_font_create_linear()?
+
+- Add hb_shape_plan()/hb_shape_execute()
 
-- Make sure LangSys default feature is only applied once...
+- Add sanitize API
 
-- kern/GPOS interaction
+- Add query API for aalt-like features?
+
+- SFNT api? get_num_faces?
+
+- Full matrix instead of scale?
+
+- Add hb-glib / hb-icu script conversion API
+
+- Add segmentation API
+
+- Add hb-cairo
+
+- Add hb-fribidi
+
+
+Build fixes:
+===========
+
+- GNOME Bug 612402 - (hb-arm) HarfBuzz compilation fix for arm
 
-- Use size_t in sanitize?
 - Better define HB_INTERNAL
-- Future-proof metrics struct
 
-hb-ot:
-- Rename hb_internal_glyph_info_t to hb_ot_glyph_info_t
-- Add query API for aalt-like features
-- HB_OT_LAYOUT_GLYPH_CLASS_BASE_GLYPH vs LookupType::... mess
+
+Optimizations:
+=============
+
+- Avoid allocating blob objects internally for for_data() faces
+
+- Add caching layer to hb-ft
+



More information about the HarfBuzz mailing list