[igt-dev] [PATCH i-g-t 03/20] tests/psr: Rename psr_active() to psr_enabled()
Dhinakaran Pandiyan
dhinakaran.pandiyan at intel.com
Wed Apr 11 02:37:15 UTC 2018
psr_active() checks the debugfs flag "HW Enabled & Active bit", which only
tells us if PSR was enabled by the driver. The state of PSR - active
or inactive is different from this flag for DDI platforms, so rename the
function appropriately.
Signed-off-by: Dhinakaran Pandiyan <dhinakaran.pandiyan at intel.com>
---
tests/kms_psr_sink_crc.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/kms_psr_sink_crc.c b/tests/kms_psr_sink_crc.c
index e55d2576..1657ee8a 100644
--- a/tests/kms_psr_sink_crc.c
+++ b/tests/kms_psr_sink_crc.c
@@ -203,7 +203,7 @@ static bool sink_support(data_t *data)
strstr(buf, "Sink_Support: yes\n");
}
-static bool psr_active(data_t *data)
+static bool psr_enabled(data_t *data)
{
char buf[512];
@@ -217,7 +217,7 @@ static bool wait_psr_entry(data_t *data)
{
int timeout = 5;
while (timeout--) {
- if (psr_active(data))
+ if (psr_enabled(data))
return true;
sleep(1);
}
--
2.14.1
More information about the igt-dev
mailing list