[igt-dev] [PATCH i-g-t 7/7] kms_flip: Standardize return value for fb_is_bound

Maarten Lankhorst maarten.lankhorst at linux.intel.com
Wed Mar 6 11:25:30 UTC 2019


Op 04-03-2019 om 16:32 schreef Rodrigo Siqueira:
> The function fb_is_bound() mix integer value with booleans for handling
> the return value. This commit standardizes the return value of
> fb_is_bound() for using only booleans.
>
> Signed-off-by: Rodrigo Siqueira <rodrigosiqueiramelo at gmail.com>
> ---
>  tests/kms_flip.c | 5 ++---
>  1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/tests/kms_flip.c b/tests/kms_flip.c
> index de3ab600..abfdd363 100755
> --- a/tests/kms_flip.c
> +++ b/tests/kms_flip.c
> @@ -947,8 +947,7 @@ static void paint_flip_mode(struct igt_fb *fb, bool odd_frame)
>  	igt_put_cairo_ctx(drm_fd, fb, cr);
>  }
>  
> -static int
> -fb_is_bound(struct test_output *o, int fb)
> +static bool fb_is_bound(struct test_output *o, int fb)
>  {
>  	int n;
>  
> @@ -958,7 +957,7 @@ fb_is_bound(struct test_output *o, int fb)
>  		};
>  
>  		if (drmIoctl(drm_fd, DRM_IOCTL_MODE_GETCRTC, &mode))
> -			return 0;
> +			return false;
>  
>  		if (!mode.mode_valid || mode.fb_id != fb)
>  			return false;
>
> _______________________________________________
> igt-dev mailing list
> igt-dev at lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/igt-dev

Nice cleanup. Hope we can eventually convert kms_flip to igt_display at some point for readability.

For all except patch 4:

Reviewed-by: Maarten Lankhorst <maarten.lankhorst at linux.intel.com>

:)



More information about the igt-dev mailing list