[igt-dev] [PATCH] test/kms_content_protection: Use generic debugfs name for HDCP caps

Bhawanpreet Lakha Bhawanpreet.Lakha at amd.com
Mon Sep 23 18:23:25 UTC 2019


Rename "i915_hdcp_sink_capability" to "hdcp_sink_capability"

The content protection tests only start if this debugfs entry exists.
Since the name is specific to intel driver these tests cannot be used with
other drivers.

Remove "i915" so the debugfs name is generic.

Signed-off-by: Bhawanpreet Lakha <Bhawanpreet.Lakha at amd.com>
---
 tests/kms_content_protection.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tests/kms_content_protection.c b/tests/kms_content_protection.c
index e676b60b..a105c5de 100644
--- a/tests/kms_content_protection.c
+++ b/tests/kms_content_protection.c
@@ -554,7 +554,7 @@ static bool sink_hdcp_capable(igt_output_t *output)
 	if (fd < 0)
 		return false;
 
-	debugfs_read(fd, "i915_hdcp_sink_capability", buf);
+	debugfs_read(fd, "hdcp_sink_capability", buf);
 	close(fd);
 
 	igt_debug("Sink capability: %s\n", buf);
@@ -571,7 +571,7 @@ static bool sink_hdcp2_capable(igt_output_t *output)
 	if (fd < 0)
 		return false;
 
-	debugfs_read(fd, "i915_hdcp_sink_capability", buf);
+	debugfs_read(fd, "hdcp_sink_capability", buf);
 	close(fd);
 
 	igt_debug("Sink capability: %s\n", buf);
-- 
2.17.1



More information about the igt-dev mailing list