[igt-dev] [PATCH igt 1/3] lib/igt_debugfs: Add helper for writing debugfs files
Petri Latvala
petri.latvala at intel.com
Wed Nov 10 11:58:45 UTC 2021
On Tue, Nov 09, 2021 at 10:09:03AM -0800, Rob Clark wrote:
> From: Rob Clark <robdclark at chromium.org>
>
> Signed-off-by: Rob Clark <robdclark at chromium.org>
> ---
> lib/igt_debugfs.c | 16 ++++++++++++++++
> lib/igt_debugfs.h | 12 ++++++++++++
> 2 files changed, 28 insertions(+)
>
> diff --git a/lib/igt_debugfs.c b/lib/igt_debugfs.c
> index a5bb95ca..39431068 100644
> --- a/lib/igt_debugfs.c
> +++ b/lib/igt_debugfs.c
> @@ -351,6 +351,22 @@ void __igt_debugfs_read(int fd, const char *filename, char *buf, int size)
> close(dir);
> }
>
> +/**
> + * __igt_debugfs_write:
> + * @filename: file name
> + * @buf: buffer to be written to the debugfs file
> + * @size: size of the buffer
I see that we have this mistake in __igt_debugfs_read already but no
reason to repeat mistakes: Also document the fd parameter.
> + *
> + * This function opens the debugfs file, writes it, then closes the file.
> + */
> +void __igt_debugfs_write(int fd, const char *filename, const char *buf, int size)
> +{
> + int dir = igt_debugfs_dir(fd);
> +
> + igt_sysfs_write(dir, filename, buf, size);
> + close(dir);
> +}
> +
> /**
> * igt_debugfs_search:
> * @filename: file name
> diff --git a/lib/igt_debugfs.h b/lib/igt_debugfs.h
> index d43ba6c6..249eb56a 100644
> --- a/lib/igt_debugfs.h
> +++ b/lib/igt_debugfs.h
> @@ -40,6 +40,7 @@ int igt_debugfs_pipe_dir(int device, int pipe, int mode);
>
> int igt_debugfs_open(int fd, const char *filename, int mode);
> void __igt_debugfs_read(int fd, const char *filename, char *buf, int size);
> +void __igt_debugfs_write(int fd, const char *filename, const char *buf, int size);
> int igt_debugfs_simple_read(int dir, const char *filename, char *buf, int size);
> bool igt_debugfs_search(int fd, const char *filename, const char *substring);
>
> @@ -54,6 +55,17 @@ bool igt_debugfs_search(int fd, const char *filename, const char *substring);
> #define igt_debugfs_read(fd, filename, buf) \
> __igt_debugfs_read(fd, (filename), (buf), sizeof(buf))
>
> +/**
> + * igt_debugfs_write:
> + * @filename: name of the debugfs file
> + * @buf: buffer to be written to the debugfs file
> + *
> + * This is just a convenience wrapper for __igt_debugfs_read. See its
> + * documentation.
Same here regarding the fd parameter as above. Also copypaste mistake
with s/debugfs_read/debugfs_write/.
--
Petri Latvala
> + */
> +#define igt_debugfs_write(fd, filename, buf) \
> + __igt_debugfs_write(fd, (filename), (buf), sizeof(buf))
> +
> /*
> * Pipe CRC
> */
> --
> 2.31.1
>
More information about the igt-dev
mailing list