[igt-dev] [v3 0/4] tests/i915/kms_dsc: Reorg

Swati Sharma swati2.sharma at intel.com
Thu Jan 19 09:25:26 UTC 2023


In this patch series, helper functions for kms_dsc
are introuduced which will reduce code duplication
while creating dsc concurrent tests (eg: PSR)

This is split from https://patchwork.freedesktop.org/series/111342/
since YCBCR420 DSC required driver+igt changes.

Also, few other trivial changes are done.

Swati Sharma (4):
  lib/dsc: Move VDSC functions to separate lib file
  Move wrapper functions from kms_dsc to kms_dsc_helper
  tests/i915/kms_dsc: Add disp_ver as struct data_t member
  tests/i915/kms_dsc_helper: Improve format string

 lib/igt.h                   |   1 +
 lib/igt_dsc.c               | 133 ++++++++++++++++++++++++++++++++++
 lib/igt_dsc.h               |  19 +++++
 lib/igt_kms.c               | 127 ---------------------------------
 lib/igt_kms.h               |  10 ---
 lib/meson.build             |   1 +
 tests/i915/kms_dsc.c        | 137 ++++--------------------------------
 tests/i915/kms_dsc_helper.c |  99 ++++++++++++++++++++++++++
 tests/i915/kms_dsc_helper.h |  35 +++++++++
 tests/meson.build           |   9 ++-
 10 files changed, 308 insertions(+), 263 deletions(-)
 create mode 100644 lib/igt_dsc.c
 create mode 100644 lib/igt_dsc.h
 create mode 100644 tests/i915/kms_dsc_helper.c
 create mode 100644 tests/i915/kms_dsc_helper.h

-- 
2.25.1



More information about the igt-dev mailing list